The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Błędy:Najbardziej Irytujące Błędy 11.0 dev

Skocz do: nawigacja, szukaj

Najbardziej irytujące błędy oraz proponowane rozwiązania:

Aby uzyskać ogólne informacje na temat raportowania błędów, zobacz raportowanie błędów. Podczas testowania wersji z drzewa factory/alpha nie należy zgłaszać błędów w tłumaczeniu; z wyjątkiem tłumaczeń w wersjach beta. Zobacz także OpenSUSE Localization Guide.

Aby bezpośrednio zgłośić błąd w openSUSE 11.0, odwiedź link.


openSUSE 11.0 RC1

General

  • GRUB config broken for other partitions Bug #395085
  • USB system with EHCI might have issues in device recognition [[1]]

GNOME

  • GNOME asks for the root password on first login Bug #390658
  • GNOME has wrong icon theme by default Bug #391865
  • GNOME updater crashes on login Bug #395445 Workaround - until the fix is pushed to the update repositories you can change the ShutdownTimeout to 120 seconds in /etc/PackageKit/PackageKit.conf

KDE

  • KNetworkManager fills the system tray with 3 icons. Bug #383032

openSUSE 11.0 Beta3

General

  • after installation from LiveCD, it is imperative that you delete the file /.buildenv , otherwise your system won't boot after you upgrade the kernel because of a missing initrd file. See Bug #389177 and Bug #392054. [NB: If you happen not to be able to boot because of this, reboot with the livecd, open a console, mount your root partition (say to /mnt/root) (and the boot partition to /mnt/root/boot if necessary), then do "mount /sys --bind /mnt/root/sys", chroot to /mnt/root, delete .buildenv and run mkinitrd to create the missing initrd file.]
  • NVIDIA driver doesn't compile. Workaround: check here for a patch. No patching required if 173.14.05 drivers are used. If you want to install the nvidia legacy driver take a look here.
  • parallel driver grabs IRQ14 preventing legacy SFF ATA controller from working (Bug #375836)
  • T41p shutting down due to "temperature critical" (Bug #378327)
  • Branding not yet complete (Bug #369270)
  • Package selector doesn't show any patterns (Bug #390139)
  • SMB based (network) printer cannot be added (Bug #386934)
  • network printing via lpd fails (Bug #391848)
  • Upgrade process leaves the system with wrong permissions on some files. Run `SuSEconfig` to fix them(Bug #390930)

GNOME

  • YaST control center does not start under GNOME (Bug #389069)
  • No window decoration, workaround run compiz-manager & or metacity --replace& (Bug #387168)

KDE

  • kdm looses keyboard when detecting an unknown previous session type (Bug #389098)
  • Kontact starts with sidebar splitter on right window border (Bug #389141), Workaround: move it to left to see components
  • opensuseupdater-kde unable to start 'yast2 piwo' (Bug #389765)
  • (K)NetworkManager unable to autoidentify the right wpa (Bug #391759) Workaround: choose Expert settings and specify manually the WPA version and the specific chiper. If you don't know which use be root and check with: iwlist dev-name scan (i.e. iwlist wlan0 scan)

openSUSE 11.0 Beta2

Live-CD

Note: You can find newer Live-CDs with those fixes on ftp.suse.com

General

  • GNOME Main Menu is slow to respond (Bug #375701) Workaround: Click on volume control in the panel, Configure local sound server then check "Enable network access to local sound devices"
  • Hostname created during installation isn't being saved to /etc/hosts, and can cause slow Desktop logins and launching of apps (Bug #383336). Workaround: Add your hostname to /etc/hosts (See bug)
  • NVIDIA driver doesn't compile. Workaround: check here for a patch.
  • If you upgrade the kernel to 2.6.25.2-2-default you must run mkinitrd or your system won't boot on next reboot (Bug #389177)
su - 
cd /boot
mkinitrd

openSUSE 11.0 Beta1

Live-CD

  • x86_64 live CDs do not fit on 700MB, need to be tested with DVD-R
  • tells that you have to type kernel name which fails, just press <return> (Bug #381152)
  • Live-CD installer does not work (Bug #381259, Bug #381153)
  • memtest fails even on good RAM (Bug #359490) Workaround: use older media e.g. 10.3

DVD

  • Adding of system users is broken (Bug #381227), workaround: see below
  • Changing something in the bootloader proposal causes broken menu.lst (Bug #380781)
  • License text still from 10.3 (Bug #381158)

General

  • password exceeds 8 characters warning during installation (Bug #371147)
  • Patterns or patches will never be shown as selected (Bug #380356)
  • GNOME Main Menu (and some other apps) are slow to respond (Bug #375701) Workaround: Click on volume control in the panel, Configure local sound server then check "Enable network access to local sound devices"
  • GDM does not start, missing gdm user (Bug #381227), Fix: Reinstall gdm as below to work around
  • NVIDIA driver doesn't compile. Workaround: check here for a patch.
  • KDE4 login screen is confused about focus (Bug #381501)
  • Trashcan/desktop icons may get duplicated on every login (Bug #381191)
  • If Plasma crashes or gets killed on next login the panel is missing (Bug #381704)
  • X doesn't start in VirtualBox (Bug #374710) Workaround: Log in as root, run "sax2 -m 0=vesa" then "rcxdm restart"

Missing System Users in 11.0 Beta1

There is a Bug which affects the adding of system users in the following packages on both LiveCD and DVD installation:

  • aaa_base
  • avahi
  • beagle
  • cups
  • dbus-1
  • festival
  • fuse
  • gdm
  • hal
  • ntp
  • openssh
  • PolicyKit
  • postfix
  • pulseaudio
  • pwdutils
  • samba
  • scrollkeeper
  • uuid-runtime
  • yast2-registration

You have to reinstall them to get the correct users created on your system. You can do so either in YaST or use zypper like:

for i in aaa_base avahi beagle cups dbus-1 festival fuse \
 gdm hal ntp openssh PolicyKit postfix pulseaudio pwdutils \
 samba scrollkeeper uuid-runtime yast2-registration; \
 do rpm -q $i > /dev/null 2>&1 && zypper in -y -f -n $i; done

openSUSE 11.0 Alpha3

  • Błędy kernela w czasie instalacji na etapi wykrywania konfiguracji sprzętowej. Uzależnione od rodzaju sprzętu [wliczając VirtualBox] (Bug #371997> obejście problemu - uruchomić instalator z opcją hwprobe=-parallel,-misc.par)
  • Pole "Użyj Automatycznej Konfiguracji" może nie działać właściwie, opcja ta nie jest jeszcze dokończona.
  • Hasło dla konta root jest "*****", czuj się swobodnie, zmieniając je ;-)
  • Problemy z uruchomieniem sieci (Bug #359793), obejście problemu: rcnetwork restart.
  • Po aktualizacji plik konfiguracyjny gruba jest pusty (Bug #372351), obejściem problemu jest cp /boot/grub/menu.lst.old /boot/grub/menu.lst.
  • Instalacja z płyty KDE LiveCD powoduje uruchamianie XDM (Bug #372506). Obejściem problemu jest ostawienie w /etc/sysconfig/displaymanager DISPLAYMANAGER="kdm".
  • Brak ikon w Yast2 po uruchomieniu systemu z CD z GNOME (Bug #372569)

openSUSE 11.0 Alpha2

  • Okno postępu Ładowanie Menagera Pakietów... blokuje propozycje instalacji/aktualizacji (Bug #359235), jednak po przyjęciu propozycji nie zobaczymy zaproponowanych wartości.
  • Podczas instalowania systemu, w przypadku zmiany języka i rozdzielczości występuje błąd Linuxrc (Bug #360867). W późniejszym etapie instalacji możliwa jest zmiana tych opcji.
  • Podczas uruchamiania KDE4 mogą występować problemy z aplikacjami autostartu KDE3 (Bug #359800).
  • Aplikacje Mono nie działają na LiveCD z GNOME (Bug #359768)
  • Błąd kernela podczas uruchamiania systemu z płyty KDE LiveCD (Bug #365783)
  • Błąd zamykania systemu na komputerach Dell Precision 690 Bug #365491

openSUSE 11.0 Alpha1

  • Yast zawiesza się podczas instalowania systemu poprzez inst-sys na architekturze PPC. Spowodowane jest to błędami w pakiecie LIMAL. Wyjściem z sytuacji jest aktualizacja bezpośrednio z nowej instalcji systemu w wersji 10.3 lub 11.0 Alpha0.
  • Problem z uruchomieniem przeglądarki Firefox i klienta poczty Thunderbird (Bug #354150)
  • Instalator przestaje działać na detekcji Xorg - po zainstalowaniu trzeba ponownie uruchamiać sax2 (Bug #354386).

openSUSE 11.0 Alpha0

  • Nieaktywne linki w procesie instalacji (w etapie partycjonowanie, konfiguracji sieci, drukarki...) w Qt (Bug #346158). Konieczne jest korzystanie z przycisku [Zmień...] w dole okna dialogowego. Błąd ten nie występuje w kolejnej wersji yast2-core (-2.16.3), z repozytorium factory.
  • Niektóre okna dialogowe programu Yast, korzystające z drzewa, nie działają w środowisku Qt (Bug #346165). Błąd ten nie występuje w kolejnej wersji yast2-core (-2.16.3), z repozytorium factory. W międzyczasie można korzystać z tekstowej wersji programu Yast (opartej o NCurses).
  • Silnik nowego interfejsu użytkownika programu Yast (a.k.a. "mod-ui") zmienia wygląd niektórych okien dialogowych (Bug #345819).
  • Pierwszy etap instalacji może zakończyć się błędem "An error occurred...". Spowodowane jest to wewnętrznymi błędami programu Yast.