The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Portal:Tumbleweed/Tematy

Skocz do: nawigacja, szukaj
Icon-info.png

Kto powinien spróbować Tumbleweed? Każdy użytkownik, który chce mieć nowsze pakiety niż są dostępne w repozytoriach openSUSE Leap. Obejmuje to między innymi zaktualizowane jądro Linux, SAMBA, git, środowiska graficzne, aplikacje biurowe i wiele innych pakietów.

Tumbleweed powinien również spodobać się najbardziej zaawansowanym użytkownikom, programistom (którzy wymagają najnowszych stosów oprogramowania i IDE) oraz uczestnikom openSUSE (którzy potrzebują niezawodnej platformy, która jest jak najbliżej openSUSE Factory, pozostając jednocześnie nadający się do użytku).

Ponieważ jądro Linuksa jest bardzo często aktualizowane, użytkownicy polegający na modułach sterowników jądra innych firm, w tym sterownikach graficznych, nie powinni korzystać z dystrybucji Tumbleweed, chyba że znają się na aktualizacji tych sterowników ze źródła lub posiadają obsługiwany sprzęt. Aby uzyskać więcej informacji, zobacz sekcję „Sterowniki innych firm” poniżej.

Uwaga: dodatkowe repozytoria Packman są dostępne dla Tumbleweed!


Icon-info.png

Kto powinien korzystać z openSUSE Leap zamiast Tumbleweed?

Chociaż dołożono wszelkich starań, aby je zbudować, w tym momencie nie ma gwarancji, że wszystkie dodatkowe moduły będą dostępne w openSUSE Tumbleweed, takich jak na przykład Vmware lub Virtualbox. I chociaż repozytorium Packman Tumbleweed Essential próbuje je dostarczyć, nie ma gwarancji, że zawsze odniesie sukces z powodu niezgodności z szybko rozwijającym się jądrem systemu Linux. Problemy z zastrzeżonymi sterownikami graficznymi są podobne i nie ma gwarancji, że będą działać jutro, nawet jeśli będą działać dzisiaj. Jeśli nie wiesz, jak skompilować własne dodatkowe moduły jądra i nie chcesz się uczyć ani uważnie śledzić aktualizacji, nie używaj Tumbleweed.


Icon-usage.png

Jak wypróbować Tumbleweed?

Aby rozpocząć korzystanie z Tumbleweed, postępuj zgodnie z Instrukcja instalacji Tumbleweed

Postępuj zgodnie z listą adresową opensuse-factory, aby otrzymywać powiadomienia o aktualizacjach. Nowe migawki są wydawane tak często, jak są gotowe, a automatyczna kontrola jakości minęła. Może to być tak częste jak codzienne, ale czasem zajmuje także kilka tygodni, gdy zintegrowane są większe zmiany.


Icon-warning.png

Wydanie ciągłe (rolling release) oznacza brak aktualizacji, tylko pilne łatki i aktualizacje

Podczas aktualizacji Tumbleweed zawsze używaj metody dist-upgrade (jak pokazano poniżej). Użycie zwykłej metody aktualizacji (w tym YaST i PackageKit) zamiast metody dist-upgrade nie spowoduje przeniesienia systemu do najnowszej migawki i może powodować problemy.

Aby aktualizować Tumbleweed do najnowszej migawki, uruchom następującą komendę jako root (najlepiej w sesji ekranowej lub sesji Tmux):

zypper dup

Pamiętaj, że mogą istnieć pewne subtelności z aktualizacjami, szczególnie w przypadku wielu repozytoriów. Zobacz na przykład ostatnia dyskusja na temat korzystania z zypper dup kontra zypper up i priorytety zypper dup.


Icon-info.png

Kodeki multimedialne

Z powodu problemów licencyjnych openSUSE nie może zawierać niektórych kodeków multimedialnych, takich jak H.264. Bez tych kodeków filmy z niektórych stron internetowych, pliki muzyczne, dźwięki itp. Mogą nie zostać odtworzone. Na szczęście repozytorium Packman zapewnia te kodeki (wraz z wieloma innymi rzeczami) dla openSUSE. Więcej informacji na temat Packman można znaleźć na dodatkowe repozytoria pakietów.

Aby dodać całe repozytorium Packman i zainstalować brakujące kodeki, uruchom następujące komendy jako root:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/ packman
zypper dup --from packman

Aby dodać tylko repozytorium Packman Essentials (udostępnia kodeki, aplikacje audio i wideo) i zainstalować brakujące kodeki, uruchom następujące polecenia jako root:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/Essentials packman-essentials
zypper dup --from packman-essentials

Po zainstalowaniu kodeków z repozytorium Packman można uruchomić test Odtwarzacz wideo HTML5 YouTube, aby sprawdzić, czy H.264 działa poprawnie w przeglądarce.


Icon-warning.png

Zewnętrzne sterowniki

Ze względu na szybkie tempo aktualizacji jądra w Tumbleweed, moduły sterowników jądra innych firm mogą nie być wystarczająco szybkie, aby dogonić najnowszą wersję jądra. W mało prawdopodobnym przypadku, gdy moduł sterownika jądra nie działa na Tumbleweed, rozważ użycie zamiast tego openSUSE Leap.

Zastrzeżony sterownik NVidii ogólnie działa bardzo dobrze z Tumbleweed.

Zastrzeżone sterowniki NVidia dla serii GeForce 400 i nowszych układów GPU można łatwo zainstalować w Tumbleweed za pomocą następujących poleceń jako root:

zypper ar -f https://download.nvidia.com/opensuse/tumbleweed nvidia
zypper inr

W bardzo rzadkich przypadkach, na przykład jeśli potrzebujesz wersji beta sterownika, możesz również ręcznie zainstalować sterownik. Przeczytaj NVidia - trudna droga, aby uzyskać szczegółowe informacje. Pamiętaj również o ponownej kompilacji i ponownej instalacji sterowników innych firm przy każdym uaktualnieniu jądra w Tumbleweed.

Alternatywnie można użyć repozytorium dkms-nvidia repozytorium openSUSE Build Service. To repozytorium zawiera sterowniki NVIDIA współpracujące z dkms (moduły NVIDIA będą automatycznie rekompilowane dla każdej nowej aktualizacji jądra). Zawiera także różne wersje sterowników NVIDIA do użytku z kartami, które nie są obsługiwane lub nie zachowują się dobrze z najnowszymi sterownikami. Aby skorzystać z tego repozytorium, po prostu kliknij łącze 1 Click Install dla wersji sterownika, którą chcesz zainstalować tu lub uruchom następujące polecenia jako root 'dla najnowszego sterownika NVIDIA od dkms-nvidia:

zypper ar -f https://download.opensuse.org/\
repositories/home:/Bumblebee-Project:/nVidia:/latest/\
openSUSE_Tumbleweed/home:Bumblebee-Project:nVidia:latest.repo
zypper in dkms-nvidia

Należy pamiętać, że repozytorium dkms-nvidia nie jest oficjalnie obsługiwane, a każdy, kto zechce z niego korzystać, najprawdopodobniej będzie sam w celu rozwiązania problemów.

Jeśli chodzi o AMD, AMDGPU-PRO nie jest obsługiwane dla Tumbleweed. Tumbleweed jest dostarczany z zainstalowanym sterownikiem Radeon, który jest i tak najlepszym wyborem.


Icon-user.png

Jak mogę pomóc?

  • Możesz przetestować dystrybucję Tumbleweed i wyrazić opinię, podzielić się doświadczeniami i wziąć udział w dyskusjach rozwojowych. Aby to zrobić, wyślij mail na adres listy [mailto: opensuse-factory@opensuse.org opensuse-factory@opensuse.org].
    Możesz również wybrać otrzymywanie wiadomości z listy, wyraźnie ją subskrybując. Aby to zrobić, wyślij pustą wiadomość na adres [mailto: opensuse-factory+subscribe@opensuse.org opensuse-factory+subscribe@opensuse.org]. Pamiętaj, aby odpowiedzieć na potwierdzenie subskrypcji, które otrzymasz chwilę później - est to mechanizm pozwalający uniknąć mimowolnej subskrypcji przez inne osoby.
  • Jeśli wystąpią problemy z instancją Tumbleweed, możesz zgłosić problemy na openSUSE bugzilla
  • Jeśli tworzysz pakiety, możesz przesyłać nowe pakiety do projektu openSUSE:Factory.