The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

GNOME 3.0

Skocz do: nawigacja, szukaj

GNOME 3.0 w openSUSE 11.4

openSUSE 11.4 wydane zostało z GNOME 2.32, ale wiemy że wiele ludzi chciałoby skorzystać z eleganckiego wyglądu występującego w GNOME 3. Dlatego drużyna GNOME ciężko pracowała nad wprowadzeniem GNOME 3.0 do openSUSE 11.4. Wiemy, że je pokochasz!

Jak zaktualizować openSUSE 11.4 do GNOME 3.0

Proszę przeczytać uważnie instrukcję przed przystąpieniem do aktualizacji

Instalacja One-click (zalecana)

Na początku upewnij się, że masz otwarty terminal przed przystąpieniem do aktualizacji (będzie potrzebny do restartu systemu po zakończonej aktualizacji) i zamknij wszystkie działające aplikacje.

Następnie użyj poniższych przycisków 1-Click:

Dla architektury x86 32bit openSUSE 11.4
Oneclick.png
Dla architektury x86 64bit openSUSE 11.4
Oneclick.png

Podążaj za instrukcją wyświetloną na ekranie. Jeżeli aktualizacja została zakończona w otwartym wcześniej terminalu zrestartuj system wpisując:

$ sudo /sbin/reboot


Jeżeli zapomniałeś otworzyć terminal, kliknij prawym przyciskiem na pulpicie i wybierz opcję "Otwórz terminal".

Aktualizacja w trybie tekstowym

Jeżeli preferujesz aktualizację w trybie tekstowym zamknij wszystkie działające aplikacje i wykonaj jako root:

  • Aby mieć pewność, że aktualizacja będzie stale uruchomiona w przypadku zakończenia sesji graficznej uruchom screen:
    # screen


  • Dodaj repozytorium GNOME:STABLE:3.0:
    # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0


  • Upewnij się, że repozytorium skonfigurowane zostało w trybie automatycznego odświeżania i posiada większy priorytet niż inne repozytoria openSUSE 11.4:
    # zypper mr -p 98 -r GNOME_STABLE_3.0


  • Wykonaj aktualizację (zamknij wszystkie działające aplikacje przed rozpoczęciem):
    # zypper dup


  • Upewnij się, że motywy GNOME Shell i GNOME3 zostały zainstalowane:
    # zypper in gnome-shell metatheme-adwaita-common


  • Kiedy aktualizacja dobiegnie końca, zrestartuj swój system:
    $ sudo /sbin/reboot


FAQ

Zaktualizowałem GNOME do wersji 3.0 i mam bugi. Gdzie mogę je zgłosić?

Proszę zgłosić błąd w openSUSE 11.4 umieszczając [gnome3] w opisie błędu.

Zainstalowałem system z obrazu (openSUSE) GNOME 3 live, jak zdobyć najnowsze pakiety?
Musisz przełączyć repozytorium, które dostarczyło obecne GNOME na GNOME:STABLE:3.0. Poniżej opis jak to zrobić (jako root):

  • dodaj repozytorium GNOME:STABLE:3.0 do swojego systemu:
    # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0


  • upewnij się, że repozytorium skonfigurowane zostało w trybie automatycznego odświeżania i posiada większy priorytet niż inne repozytoria openSUSE 11.4:
    # zypper mr -p 98 -r GNOME_STABLE_3.0


  • usuń stare repozytorium:
    # zypper rr home:fcrozat:gnome3_11.4


  • wykonaj aktualizacje systemu z użyciem nowego repozytorium:
    # zypper dup


  • zrestartuj swój system (wiele bibliotek wymaga zmian w procesach).


Znane problemy

  • GNOME Shell wymaga wsparcia 3D (openGL), która nie jest stabilna w VirtualBoksie czy VMWare. Zaleca się wyłączenie obsługi 3D w tych środowiskach i użycie GNOME 3.0 w trybie awaryjnym (zostanie on wybrany automatycznie).
  • NetworkManager 0.9 wymaga GNOME 3, który zawiera następujące problemy:
    • KDE 4 błędnie wykrywa dostępność sieci: najlepiej przełączyć się na "tradycyjną metodę ifup" w opcjach sieci w YaST lub użyć apletu nm-applet (z pakietu NetworkManager-gnome) w KDE. Problem zostanie rozwiązany w kolejnym wydaniu openSUSE
    • Edycja oraz włączenie WPA-Enterprise nie jest dostępne z poziomu rozszerzenia GNOME Shell oraz panelu sieci w Centrum Sterowania GNOME. Ten problem zostanie rozwiązany wkrótce.
    • brak wsparcia dla novellvpn: problem jest obecnie badany
    • podczas konfiguracji WEP/WPA potrzebne hest hasło użytkownika root
  • konfiguracja automatycznego logowania w panelu użytkownika jest nieprawidłowa. Problem można rozwiązać używając Yast (User and Group Management / Expert Options / Login settings / Autologin) https://bugzilla.novell.com/show_bug.cgi?id=688071
  • Pytanie o hasło roota, przy aktualizowaniu repozytoriów. To dlatego, że aktualizacje bezpieczeństwa są ustawione w tryb aktualizacji automatycznej. W openSUSE 11.4 jest to ustawione domyślnie, lecz może zostać przywrócone w ustawieniach aktualizacji oprogramowania w opcji "Automatyczna instalacja" odznaczamy ją
  • Dodatkowe pakietu muszą zostać zainstalowane w przypadku używania openSUSE 11.4 bazującej na KDE
  • NAPRAWIONY Nautilus wiesza się przy wybraniu właściwości prawym przyciskiem myszy właściwości w chwili obecnej obejściem problemu jest odinstalowanie nautilus-extension-tracker-tags. Zobacz https://bugzilla.novell.com/show_bug.cgi?id=689447

Jak pomóc?

Możesz pomóc następująco:

  • testować i raportować błędy
  • pomoc przy sprawdzeniu zaraportowanych błędów
  • pomagać ludziom i raportować błędy na forach